Time Out icon Time Out
You deserve a break
Note: David is on vacation until mid-September, so replies to support queries may be delayed.
Check out the r/Dejal community on Reddit for mutual support.

Supporter but supporter rewards not registering?

TimeOut has been encouraging me to be a little more healthy in my computer usage for years — thanks for that, and I’m really glad to see 2.0 released. In fact, even before my first 60-minute trial of the supporter features expired, I became a 6-month supporter (half because I liked the new features, and half because I felt I owed support from years of benefitting from the software!)

That’s where things get weird. The main supporter feature I like is having the status in the menu bar. I click to enable that. Even though I’m a supporter, TimeOut says I’m “trying supporter rewards free” for an hour. At the end of that time, TimeOut disappears from the menubar.

(Note: as I read your response to hampei’s comment, it sounds like this is an issue of my support simply not registering, not, as I’d originally thought, it registering but not being retained.)

A few extra facts to help you seek out the bug:

It’s possible that there’s some weirdness over locales. I’m American, and my AppleID account is linked to a US credit card. That means I’m officially in the US store. However, I currently live and work in the Netherlands, and my work computer (where I use TimeOut) is, of course, located in NL and set to Dutch locale. I notice that the prices have occasionally switched between dollars and euros in the support pane, so I don’t know if that might be part of the problem. This all might have been further complicated by the fact that this was the first purchase on my new work iMac (which I got on March 1 -- I’d installed a bunch of other software, but this was the first money spent).

Other possibly useful information: when I click "restore previous purchases" and type the correct password, I get no response at all. I would have expected the 6-month-supporter option to grey out or otherwise mark "purchased" -- or at the very least, a dialog saying either "No purchases found" or "Your purchase has been restored” would be useful. Typing an incorrect password does get an "incorrect credentials" result.

The purchase does show up in my iTunes purchase history (7 March at 10:05am), so it should have gone through.

I’ve tried restarting TimeOut, restarting my computer, and deleting and re-installing TimeOut. No success. (Although I should remark that the delete/re-install didn’t delete history, so that might be a problem.)

The only other thing I can think to do is to check that I get the same behavior on my laptop. I tried the “restore purchases” button last night, and it seemed to give the same behavior as my computer (said “trying supporter rewards”), but I didn’t check that the feature actually expires after the hour.

David Sinclair's picture

Re: Supporter but supporter rewards not registering?

Thank you for trying to resolve the issue. However, it is a known problem that is affecting some people who buy through the Mac App Store. It appears there is a bug in El Capitan that causes purchases and restores to fail. If you look in the Console log, you'll see an error like storeaccountd(453) deny file-write-create.

I am working with Apple Developer Technical Support to try to resolve this, and will get a new release out ASAP to work around it, if I can.

I am very sorry that this issue has affected you and many others.

Anyone affected by this, please contact me to get a promo code to enable supporter features.

Buying the direct edition via the Dejal site is not affected.