Caboodle icon Caboodle
Lean, clean snippet machine

Yesterday's entries have disappeared

Just bought this from the MacUpdate promotion on 5/20/09 and loaded the registration info. Added a few new entries and edited some of the exiting ones.

This morning I used the Services menu to create a new Caboodle entry from an Apple Mail message and now that mail message is the only entry in Caboodle. Even the Welcome, Recipes, Gifts, S/Ns, etc. examples are missing.

No, I'm not talking about the Entries List being toggled on/off - the only entry in the entries list is the mail message.

David Sinclair's picture

Re: Yesterday's entries have disappeared

Do you have anything entered in the search field? That would limit the displayed entries to only matching ones.

No - the search field was

No - the search field was empty.

I deleted the application, the plist, the cache, and the data file. Emptied the trash. Reinstalled from the zipped download.

It worked fine. I rebuilt a lot of information.

And now it has happened again. I selected some text in a mail message and used the services menu item to create a new Caboodle entry. First time it worked. Second time I did the same thing from another mail message and everything else has gone away.

If I quit Caboodle and reopen it, only the last item shows - everything I entered since reinstalling is still gone.

The "restore defaults" button on the Preferences Advanced tab is grayed out.

I am not happy with this.

I was able to recover the

I was able to recover the missing entries by tossing out the Caboodle Data.caboodledata file and editing out the tilde ~ from the saved backup. It contained the first entry created from the Mail Services menu.

Why can't I just restore this from the Caboodle preferences pane?

David Sinclair's picture


Hmm, concerning.

I don't know what is happening; I haven't had any other reports of this behavior, and I can't recreate it myself.

I would appreciate it if you could try adding some entries (in Caboodle or via the Services item), quit Caboodle, make a copy of the data file, re-launch it, and repeat, until the behavior occurs again, and see if you can spot any pattern — in the selected item, combinations of manual / Services entry, etc.

The Caboodle preferences item isn't to restore the data, but to restore the default preferences.

David Sinclair's picture

Fixed in 1.3.2

Just a note for anyone reading the forums: thanks to Richard's patience and help in tracing this, this issue has been fixed in version 1.3.2, which I've just released.

Here's my explanation to Richard (via email) of what I found:

The problem wasn't really specific to your machine, though perhaps increased risk on your slower machine. The issue was that when loading the app, it creates an empty data header when preparing to display the window, then loads the data file. So if the Services menu request occurs in that brief interval between preparing and loading, it wouldn't have the data yet. This build added a check that the data has loaded before handling the Services operation, delaying it until it is loaded if too soon.